Debian - fwupd update error 'libfwupdplugin5_1.7.7+f_amd64.deb'

If you are experiencing an update error on a Debian based distribution, similar to:

A package failed to install. Trying to recover:
dpkg: dependency problems prevent configuration of fwupd:
fwupd depends on libfwupdplugin5 (>= 1.7.7+f); however:
Package libfwupdplugin5:amd64 is not installed.

it's likely that you've got multiple versions of libfwupdplugin installed.

At this point, remove the older plugins with the following command in Terminal:

sudo dpkg --remove libfwupdplugin4

And then install the new requirements with:

sudo apt -f install

You will then be able to install the software updates again.

Contact Us

Not finding what you're looking for? Contact Us Directly